pageadmin管理后台修改从客户端(Content=”

测试

“)中检测到有潜在危险的 Request.Form 值

前几年帮朋友坐了一个网站,网站用的是pageadmin网站管理系统,近日朋友告诉我后台无法修改了,总是提示错误。

从客户端(Content=”<p>测试</p>”)中检测到有潜在危险的 Request.Form 值。

截图如下:

从客户端(Content="<p>测试</p>")中检测到有潜在危险的 Request.Form 值

百度查阅后发现,高手提供答案如下:

.NetFrameWork 4.0 Validaterequest="false"不起作用  
要恢复到2.0的ASP.NET请求验证功能的行为,要在以下设置 Web.config中 文件添加:

<httpRuntime requestValidationMode="2.0" />

否则,即使在页面代码中添加validaterequest="false"也不起作用。

我总结如下:

说白了,就是 .NET版本的问题,进虚拟主机管理中心,找到.NET版本选择设置, 将4.0版.net改为.net2.0 3.5即可。

砚台酪-网站建设,微信公众号/小程序开发,网络营销推广,短视频营销 » pageadmin管理后台修改从客户端(Content=”

测试

“)中检测到有潜在危险的 Request.Form 值